
Einführung in die Cyber Security· Folge 19
Authentifizierung - Teil 2
Montag, 3. November 2025 · 1 h 20
Kapitelklicken springt direkt hin
Shownotes
Was ist Authentifizierung und wie hängt das mit Authentisierung und Identifizierung zusammen? Welche Technologien gibt es und wie kann man die möglichst sicher einsetzen?
Hash-Algorithmen
• de.wikipedia.org/wiki/Lawineneffekt_(Kryptogra…)
• de.wikipedia.org/wiki/Kollisionsresistenz
• de.wikipedia.org/wiki/Geburtstagsparadoxon
HMAC
• Protokoll (RFC 2104, mit MD5) (rfc-editor.org/info/rfc2104)
• Protokoll (RFC 6151, Update) (rfc-editor.org/info/rfc6151)
• Length Extension Angriff (en.wikipedia.org/wiki/Length_extension_attack)
• HMAC Anwendung bei Crypttools (cryptotools.net/hmac)
Kerberos
• Kerberos (RFC 4120) (rfc-editor.org/rfc/rfc4120)
• Microsoft Kerberos (learn.microsoft.com/en-us/windows/win32/secaut…)
li>Kerberos beim MIT (web.mit.edu/kerberos/www)
Passkeys
• Passkeys (FIDO Alliance) (fidoalliance.org/passkeys)
• Apple: Informationen zur Sicherheit von Passkeys (support.apple.com/de-de/102195)
• BSI: Passkeys - Schafft die Passwörter ab?! (bsi.bund.de/DE/Themen/Verbraucherinnen-und-Ver…)
JSON Web Tokens (JWT)
• Protokoll (RFC 7519) (rfc-editor.org/info/rfc7519)
• JSON Web Token (de.wikipedia.org/wiki/JSON_Web_Token)